Архив рубрики: Учитель

Инструкция для тех, кто хочет стать программистом с нуля

Инструкция для тех, кто хочет стать программистом с нуля

Кризис заставляет многих сменить место работы или даже полностью поменять специальность. Приходится осваивать новые навыки и профессии. Прекрасным выбором в этом случае может стать профессия программиста. Это интересно, комфортно и прибыльно. В этой статье мы постараемся ответить на вопрос, как построить карьеру программиста с нуля.

Читать далее

Решение задачи 27

На плоскости задано множество точек с целочисленными координатами. Необходимо найти минимально возможную площадь невырожденного (т. е. имеющего ненулевую площадь) треугольника, одна вершина которого расположена в начале координат, а две другие лежат на биссектрисах углов, образованных осями координат, и при этом принадлежат заданному множеству. Если такого треугольника не существует, необходимо вывести соответствующее сообщение. 
Напишите эффективную по времени и по используемой памяти программу для решения этой задачи. 
Программа считается эффективной по времени, если при увеличении количества точек в k раз время работы возрастает не более чем в k раз.  Программа считается эффективной по памяти, если размер памяти для хранения всех необходимых данных не зависит от количества точек и не превышает 1 килобайта. 
Перед текстом программы кратко опишите алгоритм решения и укажите язык программирования и его версию. 
 
Входные данные 
В первой строке задаётся N – количество точек в заданном множестве. 
Каждая из следующих строк содержит два целых числа – координаты очередной точки. 
 
Пример входных данных: 
3 
6 6 
-8 8 
9 7 
 
Выходные данные 
Если искомый треугольник существует, программа должна напечатать одно число: минимально возможную площадь треугольника, удовлетворяющего условиям. Если искомый треугольник не существует, программа должна 
напечатать сообщение: «Треугольник не существует».
Пример выходных данных для приведённого выше примера входных данных: 
48

Решение задачи
Как известно биссектриса - это крыса, которая делит угол пополам. Отсюда, можно догадаться, что точка лежащая на биссектрисе имеет одинаковую абсолютную (без знака) координату по x и y. Например: (6,6), (8,-8), (-10,-10). То есть при решении задачи для запоминании координаты точки достаточно запомнить одно число: абсолютное значение X или Y. Далее задача сводится к нахождение двух координат с минимальными абсолютными значениями, то есть в нашем случае к нахождению двух минимальных чисел. В конце нужно посчитать площадь.
Нарисуйте на бумаге треугольник с координатами (0,0),(6,6),(-4,4), вспомните теорему Пифагора и легко поймете формулу вычисления площади.path6909.
Так же нужно проверить, что такой треугольник может существовать. В нашей задаче для этого достаточно, чтобы точки не лежали на одной прямой. Для проверки этого можно перемножить знаки координат. Например, у точек (6,6) и (-4,4) произведение знаков будет -1, такой треугольник может существовать. А у точек (-4,4) и (5,-5), произведение равно +1, это вырожденный треугольник.
var
  N: integer; {количество точек} 
  x, y: integer; {координаты очередной точки} 
  tmin1, tmin2: integer; {минимальные координаты точек}
  z: Integer;{Проверка на вырожденость}
  s: real; {площадь} 
  i: integer;

begin
  readln(N); 
  tmin1 := MaxInt;tmin2 := MaxInt; 
  z:=1;
  for i := 1 to N do 
  begin
    readln(x, y); 
    if (abs(x) = abs(y)) then begin
      if abs(x) < tmin1 then begin
        tmin2 := tmin1;
        tmin1 := abs(x);
        z:=z*Sign(x)*Sign(y);
      end
        else 
      if abs(x) < tmin2 then begin
        tmin2 := abs(x);
        z:=z*Sign(x)*Sign(y);
      end;
    end;
  end; 
  if z=1 then writeln('Треугольник не существует') 
  else begin
    s := tmin1 * tmin2 / 2;     
    writeln(s);
  end;
end.

10 игр, которые научат ребёнка программированию

«Я думаю, что в будущем все, а не только программисты будут связаны с элементами программирования», — считает Марк Цукерберг. Поскольку в этом будущем придётся жить нашим детям, пора подготовить их к трудностям, то есть научить программировать.

читать далее

Языки программирования: критерии выбора

Языки программирования: критерии выбора

Вы когда-нибудь задумывались о том, почему так много языков программирования? Какие языки программирования распространены сейчас и какие будут использоваться в ближайшем будущем? Какой из языков программирования следует выбрать для изучения, чтобы использовать его в своей работе? Ответит на эти и другие вопросы ведущий программист Исследовательского центра Samsung, кандидат физико-математических наук, Евгений Зуев.

Читать далее: http://4ege.ru/video-informatika/52140-yazyki-programmirovaniya-kriterii-vybora.html

l

Авторский семинар К Ю Полякова. 3 02 2016

Авторский семинар К Ю Полякова. 

Я думаю это будет самое полезное видео для учителей информатики в 2016 г.. Так же может быть полезно, кто собирается сдавать ЕГЭ по информатике, так как там рассказывается об изменениях в ЕГЭ по информатике 2015-2016 г.

ссылка

ЕГЭ-2016. Рекомендации по информатике

ЕГЭ-2016. Рекомендации по информатике

Об экзамене по информатике рассказывает Лещинер Вячеслав Роальдович, ведущий научный сотрудник ФГБНУ «ФИПИ». Руководитель Федеральной комиссии по разработке контрольных измерительных материалов для проведения государственной итоговой аттестации по образовательным программам основного общего и среднего общего образования по информатике и ИКТ.

Читать далее: http://4ege.ru/video-informatika/52014-ege-2016-rekomendacii-po-informatike.html

Эксперты нашли зависимость между баллами ЕГЭ и зарплатой выпускников

Зарплаты выпускников качественных вузов (с высоким средним баллом приёма) на 30-40% выше, чем у молодых специалистов, окончивших «некачественные» высшие учебные заведения, следует из работы Высшей школы экономики ВШЭ.

Читать далее: http://4ege.ru/analitika/51793-eksperty-nashli-zavisimost-mezhdu-ballami-ege-i-zarplatoy-vypusknikov.html

Минимальные баллы ЕГЭ останутся на прежнем уровне

Получить школьный аттестат

Небольшая статья для учителей и репетиторов. 

Как известно, для того, чтобы получить школьный аттестат о полном среднем образовании, необходимо сдать ЕГЭ по обязательным предметам. Конечно, наш глава Минобрнауки, как-то говорил о том, что для тех детей, кто не планируют поступление в ВУЗ, будет предусмотрена возможность получения аттестата без сдачи ЕГЭ. Для того, чтобы снизить психологическую нагрузку, увеличить успеваемость и, вероятно, улучшить статистику. Пока что, каких-либо шагов по этому поводу предпринято не было. Зато остались неизменными баллы ЕГЭ по обязательным предметам и правила приема в ВУЗы.

читать далее

ЕГЭ на компьютере

С 26 по 31 октября Рособрнадзор проведёт апробацию новых экзаменационных моделей ЕГЭ по четырём учебным предметам: истории, обществознанию, географии и информатике. Экзамены будут проходить на компьютере. Апробация будет осуществляться в режиме онлайн на сайте online-gia.ru. Доступ к аккаунту выдадут перед экзаменами. Результаты будут доступны после 24 ноября 2015 года.

Источник: http://4ege.ru/ege-gia/51569-ege-na-kompyutere.html